这是来自Github的一个项目,作者创立了一种以文言文为基础的文言文编程语言,把中华传统文学语言融入了现代编程中,想法十分巧妙,趣味性十足!

访问地址:https://github.com/LingDong-/wenyan-lang
请输入图片描述

现在这个项目已经超过 10K Stars 了(昨天看还是 9K,一夜涨了 1K),咱赶紧来研究下。

学语言嘛,当然先从 “Hello world” 开始,看看文言版怎么写:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
    吾有一言。曰「「問天地好在。」」。書之。
云云。

没看懂,编译成 JavaScript:

var n = 3;
for (var i = 0; i < n; i++) {
    console.log("問天地好在。");
}

运行:

問天地好在。
問天地好在。
問天地好在。

完全的中文编程有木有,使用古汉语语法,具有图灵完整性,可以编译成 JavaScript 或 Python。

如同古人篆书一般,一顿之乎者也,程序写好了!

Hello world

Wenyan:

吾有一數。曰三。名之曰「甲」。為是「甲」遍。吾有一言。曰「「問天地好在。」」。書之。云云。Equivalent JavaScript:

var n = 3;for (var i = 0; i < n; i++) {console.log("問天地好在。");}Output:

問天地好在。問天地好在。問天地好在。Punctuations and newlines are completely optional (just like they are in Classical Chinese), so the above code is equivalent to:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云More sophisticated examples, such as the Sieve of Eratosthenes, Quicksort, Mandelbrot set, and Tower of Hanoi, can be found in the ./examples folder.

标签: none

添加新评论